I suggest you ...

Update for PRO users and RSS update

Is the extension updated anymore? I'm a PRO user but nothings changed for years....

Also the RSS doesn't update when you refresh the page, seems to use a cached version

2 votes
Sign in
(thinking…)
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Jon Bozward shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

2 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • AdminiChrome (Owner, iChrome) commented  ·   ·  Flag as inappropriate

    Hey Jon!

    Sounds like your RSS feed is having trouble updating.

    Oftentimes the issue will go away by itself once they resync. If you are still having problems, we recommend uninstalling then re-installing iChrome.

    Before you Uninstall
    Make sure your settings are saved, click on your profile picture in the upper right hand corner of iChrome and select “Settings”
    Navigate to the “Account” tab and make sure you are signed in to your Google Account
    If you are not, please sign in otherwise your settings will be lost

    To uninstall iChrome, go to Settings in your Chrome browser then More Tools-->Extensions.
    Find iChrome in your list of extensions and select “Remove”
    You will see a box asking if you are sure, then select remove.

    To reinstall, go to the Chrome Web Store Page for the extension you want to install.
    New Tab Extension: https://chrome.google.com/webstore/detail/ichrome-new-tab-a-fast-pr/iccjgbbjckehppnpajnmplcccjcgbdep?hl=en
    Home Page Extension: https://chrome.google.com/webstore/detail/ichrome-a-fast-productive/oghkljobbhapacbahlneolfclkniiami?hl=es

    Once you’ve reinstalled, click on your profile picture in the upper right corner of iChrome then select “Settings”
    Navigate to the Account tab and select “Sign in with Google”
    When prompted select “Use Account” to keep the same widgets you had installed before uninstalling

    Hope this helps, would love to hear back with results once you've tried this!

    Thanks for bringing to our attention, we're working hard on fixing all sync issues in the meanwhile!

Feedback and Knowledge Base